The issue affecting our Control Room products in the U.S. region has been fully resolved. All services are now operating normally. Please note that scheduled runs and API triggers initiated during the outage period—between 11:40 PM PDT on October 19 and 3:55 PM PDT on October 20—were likely impacted and may not have executed.
We recommend reviewing the status of affected runs in Control Room and manually re-running any missed processes as needed.
Posted Oct 21, 2025 - 07:05 UTC
Monitoring
We're monitoring issues on our US based deployments. Some of the services are recovering but at the moment there are issues with e.g. robot process run executions and scheduling.
Posted Oct 20, 2025 - 12:36 UTC
This incident affected: Robots, API, and SSO integration.